Skip to main content
← All vulnerabilities
CVE-2023-1428PYSEC-2026-1425GHSA-6628-Q6J9-W8VG

Denial-of-Service in gRPC

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.53, 1.53.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

There exists an vulnerability causing an abort() to be called in gRPC.  The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclb_client_stats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Google gRPC

    From 1.51 · fixed in 1.53

  • grpcioPyPI

    From 1.51.0 · fixed in 1.53.0

  • io.grpc:grpc-protobufMaven

    From 1.51.0 · fixed in 1.53.0

  • grpcRubyGems

    From 1.51.0 · fixed in 1.53.0

References 1

GitHub · grpc/grpc