Skip to main content
← All vulnerabilities
CVE-2023-0872GHSA-W5GQ-XRRP-3FXF

ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 32.0.2
1 Metasploit module
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • The OpenNMS Group Horizon

    From 31.0.8 · fixed in 32.0.2

  • The OpenNMS Group Meridian

    From 2020.0.0 · through 2020.1.37; From 2021.0.0 · through 2021.1.29; From 2022.0.0 · through 2022.1.18; From 2023.0.0 · through 2023.1.5

  • org.opennms:opennms-webapp-restMaven

    From 31.0.8 · fixed in 32.0.2

References 3

docs.opennms.com

GitHub · OpenNMS/opennms

GitHub · rapid7/metasploit-framework