Skip to main content
← All vulnerabilities
CVE-2023-0869GHSA-7V39-JJJ6-J4J4

Cross-site scripting in outage/list.htm

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2023.1.0, 31.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting in outage/list.htm in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • The OpenNMS Group Meridian

    From 2022.1.0 · fixed in 2023.1.0

  • The OpenNMS Group Horizon

    From 29.0.0 · fixed in 31.0.4

  • org.opennms:opennms-web-apiMaven

    through 31.0.3

References 2

GitHub · OpenNMS/opennms

docs.opennms.com