Skip to main content
← All vulnerabilities
CVE-2023-0867GHSA-MJV2-6JV4-VRG7

Multiple stored and reflected Cross-site Scripting in webapp

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2020.1.32, 2021.1.24, 2022.1.13, 31.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • The OpenNMS Group Meridian

    From 2020.1.0 · fixed in 2020.1.32; From 2021.1.0 · fixed in 2021.1.24; From 2022.1.0 · fixed in 2022.1.13

  • The OpenNMS Group Horizon

    From 26.0.0 · fixed in 31.0.4

  • org.opennms:opennmsMaven

    fixed in 31.0.4

References 2

GitHub · OpenNMS/opennms

docs.opennms.com